3.19.2010

Load Balancing 3 Speedy v3.x

bagian yang pokok dalam script Load Balance ini adalah di
firewall mangle, nat dan route … Untuk IP Address silahkan jabarkan sendiri ^ ^
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:86:6D master-port=none mtu=1500 name=local speed=1Gbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:86:6E master-port=none mtu=1500 name=spedol1 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:86:6F master-port=none mtu=1500 name=spedol2 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:86:70 master-port=none mtu=1500 name=spedol3 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment="" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:86:71 master-port=none mtu=1500 name=tproxy speed=1Gbps


/ip address
add address=109.110.32.9/24 broadcast=109.110.32.255 comment="" disabled=no interface=local network=109.110.32.0
add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no interface=spedol1 network=192.168.1.0
add address=1.1.1.1/32 broadcast=1.1.1.1 comment="" disabled=no interface=spedol1 network=1.1.1.1
add address=192.168.2.2/24 broadcast=192.168.2.255 comment="" disabled=no interface=spedol2 network=192.168.2.0
add address=192.168.3.2/24 broadcast=192.168.3.255 comment="" disabled=no interface=spedol3 network=192.168.3.0
add address=192.168.30.2/24 broadcast=192.168.30.255 comment="" disabled=no interface=tproxy network=192.168.30.0

/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server network
add address=109.110.32.0/24 comment="hotspot network" gateway=109.110.32.9 netmask=24
/ip dns
set allow-remote-requests=yes cache-max-ttl=5s cache-size=2048KiB max-udp-packet-size=512 primary-dns=202.130.209.242 secondary-dns=208.67.222.222

Untuk Load Balancing 3 Line spedol
/ip firewall mangle
add action=mark-connection chain=prerouting comment="load balancing" connection-state=new disabled=no in-interface=local new-connection-mark=satu nth=3,1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=satu disabled=no in-interface=local new-routing-mark=satu passthrough=no

add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=local new-connection-mark=dua nth=2,1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=dua disabled=no in-interface=local new-routing-mark=dua passthrough=no

add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=local new-connection-mark=tiga nth=1,1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=tiga disabled=no in-interface=local new-routing-mark=satu passthrough=no


/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=satu scope=255 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=dua scope=255 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=tiga scope=255 target-scope=10


/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=spedol1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=spedol2
add action=masquerade chain=srcnat comment="" disabled=no out-interface=spedol3
add action=masquerade chain=srcnat comment="" disabled=no src-address=109.110.32.0/24

bersambung bRo ...

Tidak ada komentar: